Русский информационный портал о Virtual Dub

.: Карта Сайта :.
  • Главная
    • Домой
  • Документация
    • Функции
    • Фильтры
    • Помощь/Статьи
  • Файлы
    • Virtual Dub
    • Дополнения
    • Разное
  • Авторы
    • О нас
    .: Авторы проекта. Просим любить и жаловать :.
    Clawhammer Любит тестировать видео карточку в 3d Mark и игрушку Mafia. Любит различную видео-аудио-оргтехнику, имеет познания(иногда возможно поверхностные :) ) о любой электро штуковине. Не любит пиво. Предоставлял помещение для наших дружных слётов и горячих обсуждений. На себя взял непосильный труд информационного заполнения сайта. | Заполнение, техническая поддержка
Unpublished Большой души человек. Любит программировать на C++. Автор многих филосовских идей и мыслей. Черпает вдохновение в хорошем вине и компании друзей. (с) Илья | Дизайн, кодинг, заполнение
Илья Любит выпить и армию. Патриот. Говорит, что за друзей готов биться до последней капли крови. Проникся идеей джихада, слава богу пока только идеей. Спонсировал наши творческие способности и возможности. | Заполнение, перевод, моральная поддержка.

    Design & Coding - Unpublished (c), 2003


  • Документация
    • Функции
    • Фильтры
    • Помощь/Статьи
  • Файлы
    • Virtual Dub
    • Дополнения
    • Разное
  • Авторы
    • О нас
    .: Дополнения для программы Virtual Dub :.
    Русификатор Русификатор для программы Virtual Dub 1.4.13. На русский переведены менюшки и окна. Help к сожалению остался не тронутым. Внимание ! Русификатор ТОЛЬКО для версии 1.4.13 к остальным версиям он не подходит. И вы можете просто испортить программу. | Скачать
VirtualDub external video filter SDK 1.05 Подбробная документация с примерами, заголовками по написанию фильтров для Virtual Dub | Скачать
VirtualDub Source Исходники программы Virtual Dub. Поставляются в соотвествии с GNU GENERAL PUBLIC LICENSE. | Скачать


    • Помощь/Статьи
  • Файлы
    • Virtual Dub
    • Дополнения
    • Разное
  • Авторы
    • О нас
    .: Лирическое отступление :.
    Здесь представлены ряд фильтров для скачивания. Воспользоваться фильтром довольно просто. Скопируйте файл с расширением *.vdf (сам фильтр) в каталог с Virtual Dub. После этого запустите Virtual Dub, зайдите в меню выбора фильтров, нажмите Load и укажите путь к фильтру. По возможности я буду проверять все фильтры, которые выкладываю. Если случилось такое, что я вдруг не смог проверить фильтр, то буду специально оговаривать. К некоторым фильтрам также прилагаются исходники - мой совет, качайте. ;). Если что то не качается или возникли какие то проблемы с установкой или эксплуатацией фильтров пишите мне - Unpublished

    .: Собственно сами фильтры :.
    Lab Filter v1.1 | Цитата из описания к фильтру : Данный фильтр предназначен для тонкой коррекции цветовых искажений. Например, для коррекции цветов на некачественно сделанных DVD дисках. | 55 Kb Фильтр
XYZ Filter v1.0b | Фильтр делает примерно тоже самое, что и предыдущий. Тонкую разницу между ними я так и не уловил | 51 Kb Фильтр
Subtitler v2.4 | Накладывает субтитры на видео поток. Не проверял! | 54 Kb Фильтр Исходник
Smart Smoother IQ v0.6 | Если верить автору то данный фильтр убирает эффеки радуги, который часто встречается в аниме мультфильмах, например в AnimEigo's Bubblegum Crisis and Pioneer's Trigun. Работает в IQ (chrominance/"colour") | 33 Kb Фильтр Исходник
Smart Smoother High Quality | Фильтр выполняет сглаживание картинки, устраняет/смазывает шумы и артефакты, которые могли появиться при сжатии. Вот смотрите примеры - исходная картинка и обработанная фильтром | 417 Kb Фильтр Исходник
White Balance | Позволяет очень точно произвести настройку белого цвета в видео потоке. Очень полезно при засветленных DVD фильмах. | 32 Kb Фильтр
ShutDown | Забавный фильтр, если его конечно можно назвать фильтром. ;) Сам по себе он никакой коррекции не производит, а просто выключает компьютер после обработки видео. Вот так запросто - поставил компьютер на ночь какой нибудь сложный фильтр накладывать, а сам спать лег - этот фильтр за вас все сделает - работу завершит, компьютер выключит, и кофе по утру сварит :) | 27 Kb Фильтр Исходник
Pseudocolor | Вообще то предназначен для монохронного изображения, чтобы придать ему цветность(палитра цветности задается пользователем), но может накладываться и на цветное изображение, для предания различных интересных эффектов цветности. ;) | 121 Kb Фильтр Исходник


    • Дополнения
    • Разное
  • Авторы
    • О нас
    .: Описание основных функций Virtual Dub на русском языке :.

    Основные функции.

  • Резать/Клеить.
  • Наложение фильтров.
  • Наложение/сохранение звуковой дорожки.
  • Раскадровка видео фрагмента.

    Virtual Dub является одной из ведущих программ монтажа и обработки видео потока. С помощью этой программы, можно легко склеить два разных куска видео, наложить звуковую дорожку, вырезать ее. Также в программе есть множество фильтров, которые накладываются на весь видео поток. Рассмотрим эти и другие функции более подробно.

    Разрезать/клеить

    Этими функциями в основом и пользуются при работе с виртуал дубом. Функции не замысловаты, есть практически в любом редакторе видео, поэтому подробно я на них останавливаться не буду. Итак, чтобы вырезать какой либо кусок из видео потока, необходимо сначала выбрать начало этого куска. Перемещаем ползунок в нижней части программы в желаемое место (ползунок не всегда чутко реагирует на действия поэтому в данном случае удобно воспользоваться функцией go to - Edit->go to... и выбрать либо желаемый номер кадра или время видео на которое нужно переместиться) и выбираем Edit->set selection start или просто на клавиатуре давим клавишу Home. Далее отмечаем конец куска и выбираем Edit->set selection end или просто End. Далее сохраняем выбранный кусок в отдельный файл (File->save stripped avi). Теперь клеить. Клеить очень просто. Открываем один кусок, далее выбираем File->Append AVI segment и второй кусок автоматически прикрепляется к первому.

    Наложение фильтров

    Фильтров, которые можно накладывать на видео поток, в виртуал дубе огромное количество. Поэкспериментируйте. Наложить фильтр можно следующим образом - Video->Filters.., далее откроется окно. В этом окне нажмите Add (добавить фильтр), выберете фильтр, который вам нужен, нажмите ОК, отконфигурируйте фильтр и...все фильтр наложен. Можно накладывать внешние фильтры, т.е. фильтры, которых нет в Virtual Dub, но которые свободно распрастраняются по всему интернету. Для этого после кнопки Add нужно нажать Load, и выбрать расположение фильтра на жестком диске. Можно накладывать несколько фильтров одновременно. Удалять фильтры кнопкой Delete.

    Наложение/сохранение звуковой дорожки

    Довольно полезная и необходимая функция. Чтобы сохранить звуковую дорожку из видео потока нужно выбрать File->Save WAV..., указать путь для сохранения. Чтобы наложить - Audio->WAV Audio...

    Раскадровка видео фрагмента

    Выделяем фрагмент, с которым мы хотим работать (см. описание фун-ции Разрезать/Клеить) и выбираем в пункте меню File->Save image sequence. Откроется окошко для сохранения раскадровки. Остановимся здесь чуть дольше. Первый пункт - префикс. Приведу пример: если бы вы все оставили без изменений, все ваши файлы назывались xxxx.tga (или xxxx.bmp), где xxxx - номер кадра. А если вы добавите префикс к примеру avto_mazda , то все ваши файлы будут называться avto_mazdaxxxx.tga (или avto_mazdaxxxx.bmp), где хххх номер кадра соответственно. Второй пункт окошка. Тоже самое, только avto_mazda будет в конце. В этом пункте возможно сменить расширение файлов раскадровки. Ввести к примеру, что нибудь такое оригинальное, например расширение asu. 3-й пункт меню - значашие цифры. Хотите чтобы значащих цифр в названии файла было 13 - ставьте туда цифру 13, хотите 8-мь ставьте 8. 4-й пункт. Выбрать формат сохранения раскадровки - tga или bmp. 5-й пункт. Интересный пункт. Не сразу начинать раскадровку видео, а создать сценарий (он создается в папке с Virtual Dub) и позже загрузить его на выполнение.
    • .: Содержание :.
    Резать/Клеить
    Наложение фильтров
    Наложение/сохранение звуковой дорожки
    Раскадровка видео фрагмента
    .: Мнение :.
    Я думаю этот раздел несколько утратил актуальность. Да и не написано тут ничего особенного - это можно прочитать в хелпах, ну или догадаться самому. :) Я думаю открыть тут "железную" колонку, кою будет вести господин Clawhammer. Что вы на этот счет думаете?


    .: Описание стандартных фильтров :.
    Обработка видео : описание основных фильтров

    2:1 reduction (high quality) - Уменьшает размер изображение по горизонтали и по вертикали ровно в 2 раза.

    3x3 average - Обрабатывает изображение, путем заменены каждого пикселя картинки на некоторый "средний пиксель", который получен после анализа соседних пикселей. :-)

    Blur и Blur more - В разной степени размывают изображение.

    Box blur - Настраиваемый фильтр размытия изображение. В настройках есть кнопка "Show preview", нажав которую можно сразу видеть результат работы фильтра.

    Brightness/Contrast - Позволяет изменить яркость и контрастность изображения.
    Deinterlace - Встроенный фильтр для устранения "гребенки". Честно говоря результат его работы мне не понравился, лучше пользоваться внешним фильтром "Smart deinterlace".

    Emboss - В Adobe Photoshop этот эффект называется "рельеф". Трудно на словах объяснить, что он делает, проще показать. :-)

    Flip horizontally - Перевернуть изображение по горизонтали.

    Flip vertically - Перевернуть изображение по вертикали.

    Grayscale - Делает изображение черно-белым.

    Invert - Инвертирует цвета.

    Levels - Фильтр позволяет корректировать уровень освещенности изображения. Предлагается, передвижением ползунков, выставить значение для самых темных/светлых пикселей, а так же некое среднее значение. Нажмите кнопку "Show Preview" что бы сразу следить за результатом работы фильтра. Так же, периодически, нажимайте кнопку "Sample frame", чтобы видеть гистограмму, по ней проще сориентироваться и проще выставить ползунки.

    Motion blur - Размывает движения. Переместившиеся объекты исчезают несразу.

    Null transform - Дословно : нулевая трансформация, т.е. сам по себе этот фильтр ничего не делает. Обычно он выбирается для подрезания неровных краев.

    Resize - Позволяет изменить размер картинки. Задайте новые размеры ширины и высоты. В списке "Filter mode" я обычно выбираю "Precise bicubic (A=-1.0)", можете поэкспериментировать и выбрать что-то на свой вкус. Нажмите кнопку "Show Preview" что бы следить за происходящим.

    Rotate - Поворачивает картинку на 90, 180 или 270 градусов.

    Rotate2 - Этот фильтр представляет более широкие возможности поворота картинки, здесь угол поворота, вы вписываете сами.

    Sharpen - Увеличивает контраст между сливающимися элементами в изображении, если попроще : увеличивает резкость изображения.

    Smoother - Размывает картинку. Фильтр позволяет задать степень размытия.

    Temporal smoother - Размывает картинку по времени. :-) Фильтр чем-то похож на "Motion blur", но эффект несколько другой.

    Threshold - Преобразует изображение в черно-белое (оттенки серого отсутствуют полностью).

    Это был всего лишь маленькй кусочек из русского help-а по VirtualDub. Полностью help можно взять отсюда
    .: Help на русском :.
    Нормальный полноценный русский хелп. Качайте тут


    .: Немного о программе Virtual Dub :.
    Добрый день, вы находитесь на неофициальном сайте посвященном программе Virtual Dub. Я надеюсь, что вы найдете для себя много полезного и интересного. Virtual Dub это одна из программ обширной линейки программного обеспечения для монтажа и редактирования видео потока. Но Virtual Dub отличается, тем что имеет большой выбор инструментов, начиная от наложений звуковых дорожек и заканчивая наложением фильтров на видео поток(подробнее вы можете посмотреть здесь) при относительной простоте пользования.
    Чтобы работать с этой программой не обязательно быть проффесионалом. Достаточно запомнить минимальный набор функций и пользоваться ими. На этом сайте вы найдете все необходимое, для того чтобы изучить эту программу. Сайт будет интересен и тем кто уже давно пользуется Virtual Dub и тем кто не знает что это такое. Здесь вы найдете множество утилит, описаний к программе Virtual Dub, ну и конечно самую последнюю версию самой программы. Итак в добрый путь и да прибудет с вами Virtual Dub.
    P.S. Все файлы, за исключением Nimo Pack Codec выложенны прямо здесь. Так что никуда мои дорогие я вас посылать не буду. Все мною закаченно собственноручно, проверенно и упакованно - качайте.
    P.P.S. Кстати оЧепЯтоК и просто Ашибок может быть довольно много. Потому что вместе со мной, а точнее сказать параллельно со мной, родилась еще врожденная неграмотность. В общем то я на нее не сетую и мы прекрасно уживаемся вместе. Так что...необессудьте.
    .: Внимание! :.
    Гостевуха временно прекратила свое функционирование, если хотите, что-то спросить, высказать какие либо пожелания пишите мне сюда virtualdub@kulichki.com
    .: Обновление :.
    Ну вот сайт и обновился наконец. Что нового. Немного переиначил раздел фильтры. Теперь он выполнен в виде таблицы для удобства скачивания. Ну естественно добавил новые фильтры. Посмотрите - там есть и очень интересные экземпляры. Далее. Раздел Помощь теперь именуется, как Помощь/Статьи. Как из названия видно здесь я буду выкладывать различные статьи так или иначе связанные с VirtualDub-м. А пока сюда я положил описание и скриншоты с примерами работы стандартных фильтров. Далее. Я думаю раздел Функции нам не нужен и хочу вместо него сделать "железную колонку", которую будет вести некий тов. Clawhammer. Очень важно ваше мнение - высказывайтесь по этому поводу в Гостевой. В разделе "Разное" я добавил программу The JPEG Wizard v2.2. Что она делает смотрите в самом разделе, но скажу однозначно - must have. Вот. Впринципе все.
    P.S. Над сайтом и его заполнением тружусь только я один (хоть в разделе "О нас" и написано совсем другое ;)), поэтому его обновление и идет так тяжело. В ходе этого у меня предложение к вам кто хочет поработать "внештатным" сотрудником этого сайта ;) и может предложить мне какие либо интересные статьи и материалы на данную тематику я буду очень благодарен. Авторы! Помогите с развитием сайта - пишите мне сюда. Вот теперь все.

    19:33 06.03.04 - Unpublished
    .: Внимание! :.
    Сайт находится в состоянии переезда, поэтому некоторые ссылки могут не работать. Приношу свои глубочайшие изменения. И еще. Если вы тут были, если вам понравился сайт или наоборот не понравился оставьте пожалуйста сообщение в гостевой книге. Это очень важно для дальнейшей судьбы сайта.
    .: Новая Версия :.
    Новую версию Virtual Dub (сейчас она 1.5.10) вы можете скачать здесь или на сайте производителя www.virtualdub.org
    .: Help на русском :.
    Нашел и выложил новый русский help. На сайте он будет лежать только в запакованном виде. Я думаю так будет всем лучше. Хелп тут
    .: Исходники :.
    Здесь вы можете скачать исходники программы Virtual Dub. Они поставляются в соттветствии GNU лицензией.


    .: Разные файлы, так или иначе относящиеся к обработке видео :.
    XiXit v0.99 Довольно забавная игрушка, с приятным 3D интерфейсом, для разминки пальцев и отдыха мозгов. Сам играю, и вам рекомендую. | Скачать
Flask В своем роде уникальная программа. По крайней мере аналогов-конкурентов у данной программы я не вижу. Конвертирует из формата *.vob (формат DVD) в формат *.avi(формат MPEG 4). Имеет множество настроек. Очень удобно. | Часть1 Часть2
DivX Pro v.5.0.2 Кодек, которым сейчас конвертят абсалютное большинство видео. Без него вряд ли у вас получится что нибудь посмотреть. | Часть1 Часть2 Часть3 Часть4
The JPEG Wizard v2.2 Оптимизирует JPEG-и. Меняет контраст, яркость и т.д. Оптимизирует в том смысле, что прямо на лету позволяет сосчитать выходной размер файла при данном сжатии. Т.е. все просто - вы двигаете ползунок конвертации, смотрите на качество картинки вверху и на размер слева, выбираете оптимальное соотношение размер/качество. Для веб-дезигнеров просто не заменимо. Весит данная чудо-прога 3,5 мегобайта. | Скачать


    .: Разные версии программы Virtual Dub. От старых до самых последних :.
    Virtual Dub 1.4.13 Virtual Dub версии 1.4.13 одна из самых распространенных версий. Именно на нее нужно ставить русификатор, который лежит в разделе Дополнения. | Скачать
Virtual Dub 1.5.2 В этой версии исправлены старые баги и добавлены новые возможности. | Скачать
Virtual Dub 1.5.10 Самая свежая и последняя версия Virtual Dub - 1.5.10 | Скачать